Zavřít reklamu

img_Terminal1Bezpečnostní technici společnosti Red Hat odhalili trhlinu v Bash Shell, který je využívaný v Linuxu a OS X. Tuto trhlinu lze použít k nasazení škodlivého kódu a to s minimálním úsilím. Vzhledem ke všudypřítomnosti Bash, může mít tento problém vliv na širokou škálu zařízení připojených k internetu a na zabezpečení webových stránek, chytrých domácích spotřebičů a serverů. Bezpečnostní technik Robert Graham poznamenal na svém blohu, že problém Bash by přirovnal k Heartbleed, který na začátku letošního roku způsobil poměrně značný poprask.

„Internetová zařízení jako jsou například kamery jsou obzvláště zranitelná, protože jejich software je postaven tak, že umožňuje spouštět Bask scripty. Navíc se tyto zařízení neaktualizují a neopravují tolik, jako ostatní zařízení a tak jsou více zranitelná. Na rozdíl od Heartbleed, který ovlivnil pouze určitou verzi OpenSSL, tato chyba je zde dlouhou, opravdu dlouhou dobu. To znamená, že existuje spousta starých zařízení, která jsou touto chybou taktéž ohrožena. Počet zařízení, které bude nutné opravit, ale nebude je možné opravit, je mnohem větší než u Heartbleed,“ uvedl Robert Graham. Apple prozatím podle StackExchange problém neopravil a ani nejnovější verze OS X Mavericks 10.9.5 nepřináší řešení.

Bash_screenshot
Zdroj: Redakce Letem světem Applem

Související články

Dnes nejčtenější