Zavřít reklamu

Mac App Store iconPrestali vám fungovať aplikácie ako napríklad 1Password, Acorn, DaisyDisk alebo Tweetbot? Tak potom nie ste sami. Ak sa vám u týchto (a ďalších) aplikácií začala zobrazovať hláška, že je aplikácia poškodená, nemôže byť otvorená a musíte ju preinštalovať, potom chyba nie je na vašej strane, ale môžu za ne expirované bezpečnostné certifikáty, ktorých platnosť skončila 11. novembra/listopadu 2015 a vďaka tomu sa aplikácie nedarí spustiť na počítačoch so systémom OS X Yosemite alebo OS X El Capitan. Že je na vine spomínaný certifikát, si všimol tvorca Tweetbotu Paul Haddad, ktorý to potvrdil, ako inak, na Twitteri. Zároveň ale špekuloval, že tým, že aplikácia využíva SHA256 šifrovanie, sa môžu problémy objaviť aj na starších verziách systému OS X.

Pokiaľ ide o nemožnosť používať aplikácie na systéme El Capitan, potom môže byť na vine, že sa viaceré aplikácie súčasne snažia kontaktovať servery Applu, čím dochádza k nechcenému DDOS útoku na službu, ktorá generuje tickety pre aplikácie, ktoré využívajú internetovú komunikáciu. Vývojár zároveň prišiel na možné spôsoby ako vyriešiť problém s nefunkčnými aplikáciami. Zatiaľ čo v niektorých prípadoch stačí, aby užívateľ reštartoval svoj Mac so systémom Yosemite alebo novším, v iných prípadoch je treba preinštalovať aplikácie. Alternatívou je odhlásiť sa a znovu prihlásiť k svojmu Apple ID. Napokon, niektoré aplikácie už problém nemajú a to preto, lebo Apple vypustil nový certifikát s dátumom platnosti do roku 2035.

Mac App Store Damaged Apps

*Zdroj: MacRumors

 

Související články

Dnes nejčtenější