Zavřít reklamu

Bezpečnost uživatelů a jejich dat je pro Apple jednou z hlavních priorit, což ostatně potvrzují  mnohé novinky, které Apple v posledních letech představil. S drobnou, leč užitečnou bezpečnostní vychytávkou, přichází nyní o do svého Online Storu. Ten totiž nově kvůli snaze eliminovat potenciální online hrozby nespustíte na starších verzích macOS a Safari.

Design Online Storu se za poslední roky vcelku výrazně změnil:

Omezení kompatibility Online Storu Applu si jako první všiml japonský portál Mac Otakara, kterému se záhy podařilo zjistit, že je pro spuštění oficiálního internetového obchodu Applu zapotřebí alespoň OS X 10.10.5 Yosemite nebo Safari ve verzi 10.1.2. Na všech straších verzích vám při pokusu navštívit Online Store vyskočí chybová hláška upozorňující na nepodporovanou verzi macOS či prohlížeče s tím, že vás odkáže na nejnovější verze Chromu či Firefoxu, nebo na upgrade vašeho macOS a Safari. Díky tomuto kroku je tak výrazně sníženo riziko zneužití některých chyb, které sužovaly právě starší verze jablečného prohlížeče a počítačového systému. Co přesně je zneužitelné však samozřejmě zůstává nejasné.

Nejedná se o jedinou novinku cílící na bezpečnost, jejíhož představení jsme se v posledních týdnech dočkali. Na úvodní Keynote WWDC19 totiž Apple představil novou přihlašovací možnost Sign in with Apple, která má být přímým konkurentem řešení od Facebooku a Googlu. Její největší zbraní má být anonymita – po jejímž zvolení pro přihlášení k určité službě totiž bude moci její uživatel zvolit možnost pro vygenerování anonymního mailu, který bude vývojáři k dispozici pro sběr dat z aplikace. Zjednodušeně se tak dá říci, že vaše data sice budou vývojářům k dispozici, avšak nikdo nebude vědět, že jsou zrovna vás. Nezbývá tedy než doufat, že bude vše fungovat na výbornou.

Související články

Dnes nejčtenější