Zavřít reklamu

V pátek 3. května přestala fungovat rozšíření v prohlížeči Firefox. Chybu způsobil certifikát o ukončení platnosti, který už ale provozovatel opravil. Chyba byla nejdříve řešena hotfixem, nakonec však muselo dojít k vydání nové verze prohlížeče 66.0.4. Problémy byly sice odstraněny, ale smůlu mají uživatelé, kteří odmítají upgradovat starší verzi Mozilla Firefox, a vyhrožují, že přejdou na jiný prohlížeč.

K problémům došlo z pátku na sobotu, když řada uživatelů zjistila, že dříve fungující doplňky najednou nereagují. Většina to řešila stažením nových rozšíření z on-line archivů Firefoxu, která se ovšem ani nepodařilo nainstalovat. Nakonec se ukázalo, že byl certifikát platný do 3. května 2019, a následující den proto zažil prohlížeč výpadek.

Mozilla vyzvala uživatele, aby neodstraňovali ani neinstalovali žádné doplňky, problém prý bude vyřešen automaticky. Následně aplikovala hotfix, tedy rychlou opravu, která byla nainstalována na pozadí přes funkci Studie. Krátce nato došlo k vydání nové plnohodnotné verze prohlížeče, která koresponduje s desktopovými systémy a Androidem. Vývojáři uznávají, že ani tohle řešení není ideální, ale jejich cílem bylo, aby všechny funkce zprovoznily do pondělí, tedy ještě před začátkem pracovního týdne. Po aktualizaci došlo k opravě řetězce certifikátů, díky čemuž lze opět povolit webová rozšíření, motivy, vyhledávače a jazykové balíčky, které byly během víkendu zakázány.

To se ovšem nelíbí uživatelům, kteří se brání upgradu na verzi 66, a hrozí, že přejdou na jiný webový prohlížeč, pokud nedojde k vydání opravy také pro starší verze. Ty totiž využívají někteří kvůli zastaralému OS nebo z důvodu, že některá rozšíření fungují pouze se starší verzí Mozilla Firefox, ale s novější by byly nepoužitelné. Společnost zatím neví, jestli a jak takovým uživatelům pomůže, řešení jejich problému zřejmě nebude možné.

Firefox, výpadek - certifikát

Dnes nejčtenější

Další články