Zavřít reklamu

Ako sa ukazuje, ani iOS 6 či OS X Mountain Lion nie sú úplne odolné voči hrozbám. Zvláštnosťou však je, že táto chyba sa nachádza len u oficiálnych verzií softvéru a nedotýka sa žiadnej beta verzie OS X 10.8 ani iOS 6, a rovnako je zrejmé, že Apple túto chybu opravil v iOS 7 a OS X 10.9 Mavericks. Pre spustenie samotnej chyby stačí v aplikáciách Správy alebo Safari načítať určitý arabský text, ktorý následne spôsobí kolaps služieb Správy, iMessages, a Safari v oboch systémoch. Za všetkým pritom stojí rozhranie WebKit, ktoré nevyužíva len Apple, ale aj Google v prehliadači Chrome.

Ešte zvláštnejšie vyznie fakt, že vývojári a hackeri upozornili Apple na chybu už pred šiestimi mesiacmi, no Apple sa rozhodol chybu opraviť až v nových verziách svojich systémov. Práve jeho prácu si vzali na starosť hackeri, ktorí vytvorili patch pre jailbreaknuté iOS 6 zariadenia. Chybný riadok toho dokáže skutočne veľa – nielen, že dokáže zablokovať spomínané služby, ale tiež môže blokovať skenovanie SSID, pokiaľ sa v okolí nachádza WiFi sieť s týmto menom.

screen-shot-2013-08-29-at-9-47-44-am
Zdroj: Redakce Letem světem Applem - Apple magazín
*Zdroj: 9to5mac

Související články

Dnes nejčtenější